Paynow not showing on my checkout page


Hi everyone, i have generated mechant IDs for both USD and ZWL payments on my website and added them respectively but still paynow is not appearing on checkout pages, any idea how this can be resolved?


Did you turn on the toggle button on Woocommerce Payment.

Also try to use only usd or zwl


I managed to work out it’s probably a blocks error and Paynow integration not yet being supported! I worked around it by editing the template page or creating a new checkout page and using the shortcode block: [woocommerce_checkout]

Not ideal but it get your checkout back working!