WooCommerce Paynow plugin error


#1

Hello, I’ve just been introduced to the Woocommerce Paynow plugin.

After activation, each time I try to enable the payment gateway and hit save, its auto-disabling. I’ve tried the same procedure with other payment gateways available, they remain enabled and I can go ahead and set them up.

How do I ensure it remains enabled so that I go ahead and set it up?


#2

Hi @Vimbainashe

Please check that your WooCommerce Currency is set to USD $. Paynow currently only supports USD. After that then click the image button next to the Paynow payment option and paste in your Integration ID and Key and save.

Make sure this is option is checked.


#3

Hi,

I am checking the enable Paynow box but it is automatically unchecking itself when I hit save, so I’m unable to move on to the next step of set up.

This isn’t happening with the other payment options, find screenshot attached:


#4

Have you confirmed that your WooCommerce Currency is set to United States $ as shown below? Any other currency will cause the plugin to auto-disable.

image

When your currency is anything but USD you will get this error:


#5

Thanks, I can now access the set up, in the paynow account now, where do I access Merchant ID and Key set as required fields?


#6

Great to hear. You can find instructions on how to generate and get your ID and Key here: https://developers.paynow.co.zw/docs/integration_generation.html